Resolved
Maintenance complete, major issues resolved.
Identified
Ongoing maintenance on the platform
We've temporarily blocked access to csgoroll.com, csgoroll.gg and csgorolltr.com as we're doing some in-place testing on the production instance.
Investigating
We're experiencing an issue with our CDN service, which happened to coincide with our scheduled maintenance. We'll update this space with progress as we have more news.