CSGORoll

Experiencing CDN Issues
Resolved·Full outage

The issue has been resolved, and everything is back to normal.

Fri, Dec 5, 2025, 09:19 AM
(3 days ago)
·
Affected components
Updates

Resolved

The issue has been resolved, and everything is back to normal.

Fri, Dec 5, 2025, 09:19 AM

Identified

Our third party CDN service is experiencing issues, and thus negatively affecting our site. We're closely monitoring the situation and will update as we get more news.

Fri, Dec 5, 2025, 09:09 AM(10 minutes earlier)